您好,欢迎访问利联科技官网!    24小时服务热线:400-161-0880    新上东莞BGP服务器火爆热销中!登录  /  注册

【漏洞预警】Apache Solr Velocity模版注入远程命令执行漏洞

 

2019年10月31日,阿里云官方应急响应中心监测到国外安全研究人员披露了Apache Solr Velocity模版注入远程命令

执行漏洞。攻击者通过构造特定的请求,成功利用该漏洞可直接获取服务器权限。


漏洞描述:

Solr中存在VelocityResponseWriter组件,攻击者可以构造特定请求修改相关配置,使VelocityResponseWriter组件

允许加载指定模板,进而导致Velocity模版注入远程命令执行漏洞,攻击者利用该漏洞可以直接获取到服务器权限。阿

里云应急响应中心提醒Solr用户尽快采取安全措施阻止漏洞攻击。


影响版本:Apache Solr


安全建议:

目前Apache Solr官方未发布该漏洞的补丁,请关注Solr官方以便获取更新信息。

安全狗软防和金盾可对应做相关的防御

我们会关注后续进展,请随时关注官方公告。


您可能还会对下面的文章感兴趣: